I'm getting all these error messages that say "unmet peer dependency." You should have documentation on how to resolve this (even if it means reminding us of package manager basics.)
Basically, Strapi can't find the version of React it's looking for. It's hard for me to dissect the log, looks like @bn-digital/strapi-plugin-field-uuid > @strapi/design-system@1.14.1" has unmet peer dependency "react-dom@^17.0.0 || ^18.0.0".
I should know what I'm doing and have zero problems. I might be rusty on the the technicalities of yarn, npm, forcing installs, installing globally, etc.
Also, it could be an error from a plugin that I stalled a while ago. However, I have no idea what would happen to my project if I just took those plugins out.
It's also not clear at all what would happen to your database and your JSON files if I just "reinstalled" Strapi.